summaryrefslogtreecommitdiff
path: root/libmate-desktop/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-05-10 00:19:46 +0200
committerinfirit <[email protected]>2014-11-28 08:44:02 +0100
commitf2219d2afd13fd8dcfe6a35353828f4f143e8b48 (patch)
tree5714b398073883c8999a244c6f937d52887f2a13 /libmate-desktop/Makefile.am
parent7056b2ab291f998496cf7ceb3cf24b37f407eb7f (diff)
downloadmate-desktop-f2219d2afd13fd8dcfe6a35353828f4f143e8b48.tar.bz2
mate-desktop-f2219d2afd13fd8dcfe6a35353828f4f143e8b48.tar.xz
Add support for GObjectIntrospection
Turned all GnomeRR structures into boxed types, then added the needed annotations and the Makefile.am bits. Does not yet include API changes, but should bind (awfully) all of libgnome-desktop. Based on gnome commit: cad94246fb5be76482212407a380cd75f9e7b932 url: https://git.gnome.org/browse/gnome-desktop/commit/?id=cad94246fb5be76482212407a380cd75f9e7b932
Diffstat (limited to 'libmate-desktop/Makefile.am')
-rw-r--r--libmate-desktop/Makefile.am40
1 files changed, 35 insertions, 5 deletions
diff --git a/libmate-desktop/Makefile.am b/libmate-desktop/Makefile.am
index 3e35321..3f8a6e5 100644
--- a/libmate-desktop/Makefile.am
+++ b/libmate-desktop/Makefile.am
@@ -31,8 +31,9 @@ AM_CFLAGS = $(WARN_CFLAGS)
noinst_PROGRAMS = test-ditem test
-libmate_desktop_2_la_SOURCES = \
- mate-desktop-item.c \
+CLEANFILES =
+
+introspection_sources = \
mate-desktop-utils.c \
mate-desktop-thumbnail.c \
mate-thumbnail-pixbuf-utils.c \
@@ -45,12 +46,16 @@ libmate_desktop_2_la_SOURCES = \
mate-rr.c \
mate-rr-config.c \
mate-rr-labeler.c \
- mate-rr-private.h \
mate-colorbutton.c \
mate-colorsel.c \
mate-colorseldialog.c \
- edid-parse.c \
- edid.h \
+ edid-parse.c
+
+libmate_desktop_2_la_SOURCES = \
+ $(introspection_sources) \
+ mate-desktop-item.c \
+ mate-rr-private.h \
+ edid.h \
private.h
libmate_desktop_2_la_LIBADD = \
@@ -89,6 +94,31 @@ pnpdata_DATA_dist = pnp.ids
check:
test -s $(top_srcdir)/libmate-desktop/pnp.ids
+-include $(INTROSPECTION_MAKEFILE)
+INTROSPECTION_GIRS =
+INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir) --warn-all
+INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
+
+if HAVE_INTROSPECTION
+
+MateDesktop-2.0.gir: libmate-desktop-2.la
+MateDesktop_2_0_gir_INCLUDES = GObject-2.0 Gtk-$(GTK_API_VERSION) GConf-2.0
+MateDesktop_2_0_gir_PACKAGES = gdk-pixbuf-2.0 glib-2.0 gobject-2.0 gio-2.0 gtk+-$(GTK_API_VERSION) gconf-2.0
+MateDesktop_2_0_gir_CFLAGS = -DMATE_DESKTOP_USE_UNSTABLE_API -I$(top_srcdir)
+MateDesktop_2_0_gir_LIBS = libmate-desktop-2.la
+MateDesktop_2_0_gir_FILES = $(introspection_sources) $(libmate_desktop_HEADERS)
+MateDesktop_2_0_gir_SCANNERFLAGS = --identifier-prefix=Mate --symbol-prefix=mate_
+INTROSPECTION_GIRS += MateDesktop-2.0.gir
+
+girdir = $(datadir)/gir-1.0
+gir_DATA = $(INTROSPECTION_GIRS)
+
+typelibdir = $(libdir)/girepository-1.0
+typelib_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
+
+CLEANFILES += $(gir_DATA) $(typelib_DATA)
+endif
+
EXTRA_DIST = \
mate-desktop-2.0.pc.in \
mate-desktop-2.0-uninstalled.pc.in \