summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarty E. Plummer <[email protected]>2019-05-21 17:02:04 -0500
committerraveit65 <[email protected]>2019-05-22 10:30:33 +0200
commit7db1a953a39dc89585ae12fb6632a05fd04be5cd (patch)
tree7ee1c663bfb4e98c714d4009a26f5f01fc565136 /meson.build
parenta30185610beb815648854207cb2a29d0fa9303dc (diff)
downloadmate-desktop-7db1a953a39dc89585ae12fb6632a05fd04be5cd.tar.bz2
mate-desktop-7db1a953a39dc89585ae12fb6632a05fd04be5cd.tar.xz
add abi check
Signed-off-by: Marty E. Plummer <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cdd701a..7ca7c5e 100644
--- a/meson.build
+++ b/meson.build
@@ -52,6 +52,7 @@ age = 1
libversion = '@0@.@1@.@2@'.format(current, age, revision)
cc = meson.get_compiler('c')
+nm = find_program('nm')
config_h = configuration_data()
@@ -112,3 +113,12 @@ configure_file(
)
meson.add_install_script('utils/post_install.py')
+
+test('libmate-desktop symbols check',
+ find_program('abi-check'),
+ env: [
+ 'LIB=@0@'.format(libmate_desktop.full_path()),
+ 'NM=@0@'.format(nm.path()),
+ 'ABI=@0@/libmate-desktop/mate-desktop.abi'.format(meson.source_root())
+ ]
+)