summaryrefslogtreecommitdiff
path: root/schemas/meson.build
diff options
context:
space:
mode:
authorMarty E. Plummer <[email protected]>2019-05-21 17:01:18 -0500
committerraveit65 <[email protected]>2019-05-22 10:30:33 +0200
commita30185610beb815648854207cb2a29d0fa9303dc (patch)
tree02b0804e1644da72d6ddb3f2e01facaee0fa81a9 /schemas/meson.build
parente98858d43feb08d52ba6e1f39532f618b1a2cc01 (diff)
downloadmate-desktop-a30185610beb815648854207cb2a29d0fa9303dc.tar.bz2
mate-desktop-a30185610beb815648854207cb2a29d0fa9303dc.tar.xz
treewide: add meson build
Signed-off-by: Marty E. Plummer <[email protected]>
Diffstat (limited to 'schemas/meson.build')
-rw-r--r--schemas/meson.build41
1 files changed, 41 insertions, 0 deletions
diff --git a/schemas/meson.build b/schemas/meson.build
new file mode 100644
index 0000000..6397445
--- /dev/null
+++ b/schemas/meson.build
@@ -0,0 +1,41 @@
+schemas_data = configuration_data()
+schemas_data.set('GETTEXT_PACKAGE', meson.project_name())
+schemas_data.set('datadir', matedt_datadir)
+
+schemas_in = [
+ 'org.mate.background.gschema.xml',
+]
+
+schemas = []
+foreach s: schemas_in
+ schemas += configure_file(
+ input: '@[email protected]'.format(s),
+ output: '@0@'.format(s),
+ configuration: schemas_data,
+ )
+endforeach
+
+schemas += [
+ 'org.mate.accessibility-keyboard.gschema.xml',
+ 'org.mate.accessibility-startup.gschema.xml',
+ 'org.mate.applications-at-mobility.gschema.xml',
+ 'org.mate.applications-at-visual.gschema.xml',
+ 'org.mate.applications-browser.gschema.xml',
+ 'org.mate.applications-calculator.gschema.xml',
+ 'org.mate.applications-office.gschema.xml',
+ 'org.mate.applications-terminal.gschema.xml',
+ 'org.mate.debug.gschema.xml',
+ 'org.mate.file-views.gschema.xml',
+ 'org.mate.interface.gschema.xml',
+ 'org.mate.lockdown.gschema.xml',
+ 'org.mate.peripherals-keyboard.gschema.xml',
+ 'org.mate.peripherals-mouse.gschema.xml',
+ 'org.mate.sound.gschema.xml',
+ 'org.mate.thumbnail-cache.gschema.xml',
+ 'org.mate.thumbnailers.gschema.xml',
+ 'org.mate.typing-break.gschema.xml',
+]
+
+install_data(schemas,
+ install_dir: join_paths(get_option('datadir'), 'glib-2.0/schemas'),
+)