summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-09-21 08:29:20 +0200
committerStefano Karapetsas <[email protected]>2013-10-03 14:21:17 +0200
commit65a70b42c20307871a82bee3b92a42caaa6c8abb (patch)
tree3d34a7aae42187cec4c1734fff265e2d94930db4 /tools/Makefile.am
parent08b894ae5dcd858e356be6bd396b05b1cd718f3d (diff)
downloadmate-desktop-65a70b42c20307871a82bee3b92a42caaa6c8abb.tar.bz2
mate-desktop-65a70b42c20307871a82bee3b92a42caaa6c8abb.tar.xz
Move mate-conf-import to tools dir
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 399fb83..65faf6d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,3 +1,14 @@
-bin_SCRIPTS = mate-gsettings-toggle.sh
+bin_SCRIPTS = mate-gsettings-toggle
-EXTRA_DIST = $(bin_SCRIPTS)
+if MATE_CONF_IMPORT_ENABLED
+@INTLTOOL_DESKTOP_RULE@
+
+desktopdir = $(datadir)/applications
+desktop_in_files = mate-conf-import.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+bin_SCRIPTS += mate-conf-import
+endif
+
+EXTRA_DIST = $(bin_SCRIPTS)
+
+CLEANFILES = mate-conf-import.desktop