summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 16bda37..89bb457 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,13 @@ AC_SUBST(LT_VERSION)
AM_MAINTAINER_MODE
-IT_PROG_INTLTOOL([0.40.0])
+# GLib min/max required versions
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs added after GLib 2.36])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs deprecated before GLib 2.36])
+
+IT_PROG_INTLTOOL([0.50.1])
AC_PROG_CC
AC_STDC_HEADERS
@@ -295,10 +301,29 @@ docs/reference/mate-desktop/Makefile
mate-version.xml.in
po/Makefile.in
schemas/Makefile
+schemas/org.mate.accessibility-keyboard.gschema.xml
+schemas/org.mate.accessibility-startup.gschema.xml
+schemas/org.mate.applications-at-mobility.gschema.xml
+schemas/org.mate.applications-at-visual.gschema.xml
+schemas/org.mate.applications-browser.gschema.xml
+schemas/org.mate.applications-office.gschema.xml
+schemas/org.mate.applications-terminal.gschema.xml
+schemas/org.mate.background.gschema.xml
+schemas/org.mate.debug.gschema.xml
+schemas/org.mate.file-views.gschema.xml
+schemas/org.mate.interface.gschema.xml
+schemas/org.mate.lockdown.gschema.xml
+schemas/org.mate.peripherals-keyboard.gschema.xml
+schemas/org.mate.peripherals-mouse.gschema.xml
+schemas/org.mate.sound.gschema.xml
+schemas/org.mate.thumbnail-cache.gschema.xml
+schemas/org.mate.thumbnailers.gschema.xml
+schemas/org.mate.typing-break.gschema.xml
man/Makefile
tools/mate-color-select.desktop.in
tools/mate-conf-import.desktop.in
tools/Makefile
+icons/Makefile
])
AC_OUTPUT