summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 470f07f..13a45ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,10 +32,8 @@ AM_MAINTAINER_MODE
IT_PROG_INTLTOOL([0.40.0])
-AC_ISC_POSIX
AC_PROG_CC
AC_STDC_HEADERS
-AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
PKG_PROG_PKG_CONFIG
@@ -74,6 +72,12 @@ if test "x$enable_deprecation_flags" = "xyes"; then
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
+# GLib min/max required versions
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs added after GLib 2.36])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs deprecated before GLib 2.36])
+
# Should we build mate-about? Useful for people who need to build
# two mate-desktop using two different versions of GTK+
AC_ARG_ENABLE([mate-about],
@@ -127,8 +131,6 @@ dnl it too, or it will never make it into the spec file!
dnl ----------------------------------------------------------------------------
dnl GTK library version
dnl ----------------------------------------------------------------------------
-GTK_API_VERSION=2.0
-GTK_REQUIRED=2.24.0
AC_MSG_CHECKING([which gtk+ version to compile against])
AC_ARG_WITH([gtk],