summaryrefslogtreecommitdiff
path: root/icons/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'icons/meson.build')
-rw-r--r--icons/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/icons/meson.build b/icons/meson.build
new file mode 100644
index 0000000..a731eb1
--- /dev/null
+++ b/icons/meson.build
@@ -0,0 +1,17 @@
+icons = [
+ '16x16/apps/mate-desktop.png',
+ '22x22/apps/mate-desktop.png',
+ '24x24/apps/mate-desktop.png',
+ '32x32/apps/mate-desktop.png',
+ '48x48/apps/mate-desktop.png',
+ '128x128/apps/mate-desktop.png',
+ 'scalable/apps/mate-desktop.svg',
+ 'scalable/apps/mate-desktop-symbolic.svg',
+]
+
+foreach i : icons
+ dir = i.split('/')
+ install_data(i,
+ install_dir: join_paths('share/icons/hicolor', dir[0], dir[1]),
+ )
+endforeach