summaryrefslogtreecommitdiff
path: root/libmate-desktop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmate-desktop/Makefile.am')
-rw-r--r--libmate-desktop/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/libmate-desktop/Makefile.am b/libmate-desktop/Makefile.am
index 3854e81..98c9c00 100644
--- a/libmate-desktop/Makefile.am
+++ b/libmate-desktop/Makefile.am
@@ -1,5 +1,6 @@
libmate_desktopdir = $(includedir)/mate-desktop-2.0/libmate-desktop
libmate_desktop_HEADERS = \
+ mate-desktop.h \
mate-desktop-utils.h \
mate-desktop-item.h \
mate-dconf.h \
@@ -24,7 +25,7 @@ AM_CPPFLAGS = \
AM_CFLAGS = $(WARN_CFLAGS)
-noinst_PROGRAMS = test-ditem
+noinst_PROGRAMS = test-ditem test
libmate_desktop_2_la_SOURCES = \
mate-desktop-item.c \
@@ -53,6 +54,13 @@ libmate_desktop_2_la_LDFLAGS = \
-version-info $(LT_VERSION) \
-no-undefined
+test_SOURCES = \
+ test.c
+
+test_LDADD = \
+ libmate-desktop-2.la \
+ $(MATE_DESKTOP_LIBS)
+
test_ditem_SOURCES = \
test-ditem.c