summaryrefslogtreecommitdiff
path: root/mate-about/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-about/Makefile.am')
-rw-r--r--mate-about/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/mate-about/Makefile.am b/mate-about/Makefile.am
new file mode 100644
index 0000000..d56ac71
--- /dev/null
+++ b/mate-about/Makefile.am
@@ -0,0 +1,24 @@
+bin_PROGRAMS = mate-about
+mate_about_SOURCES = mate-about.c mate-about.h
+mate_about_CFLAGS = $(MATE_ABOUT_CFLAGS) $(UNIQUE_CFLAGS)
+mate_about_LDADD = $(MATE_ABOUT_LIBS) $(UNIQUE_LIBS)
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(MATE_ABOUT_CFLAGS) \
+ -DLOCALE_DIR=\"$(datadir)/locale\" \
+ -DPIXMAPS_DIR=\"$(datadir)/pixmaps/\"
+
+@INTLTOOL_DESKTOP_RULE@
+
+pixmapdir = $(datadir)/pixmaps
+pixmap_DATA = nyan-cat.gif
+
+desktopdir = $(datadir)/applications
+desktop_in_files = mate-about.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+CLEANFILES = mate-about.desktop mate-about
+
+#-include $(top_srcdir)/git.mk
+