summaryrefslogtreecommitdiff
path: root/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
new file mode 100644
index 0000000..86fc703
--- /dev/null
+++ b/tools/meson.build
@@ -0,0 +1,18 @@
+executable('mate-color-select',
+ 'mate-color-select.c',
+ c_args: [
+ '-DLOCALE_DIR="@0@"'.format(join_paths(get_option('prefix'), get_option('localedir'))),
+ ],
+ dependencies: [ gtk_dep, libmate_desktop_dep, ],
+ include_directories: top_inc,
+ install: true,
+)
+
+i18n.merge_file(
+ input: 'mate-color-select.desktop.in',
+ output: 'mate-color-select.desktop',
+ type: 'desktop',
+ po_dir: '../po',
+ install: true,
+ install_dir: join_paths(get_option('datadir'), 'applications'),
+)