summaryrefslogtreecommitdiff
path: root/mate/24x24/categories/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-08-20 17:54:20 +0200
committerrbuj <[email protected]>2019-08-21 16:42:19 +0200
commit4f18c0da4c9d1640636928b99782dad03f86f61e (patch)
tree8c88e7bcf62e873860b9ff80d88d6bac1e19597d /mate/24x24/categories/Makefile.am
parentdd933f6aaa2359e357bc668df46aea10c8dc5b20 (diff)
downloadmate-icon-theme-4f18c0da4c9d1640636928b99782dad03f86f61e.tar.bz2
mate-icon-theme-4f18c0da4c9d1640636928b99782dad03f86f61e.tar.xz
Upscale 22x22px icons to 24x24px adding 1px to the edges
Helper script: dirs=() for dir in $(find ./mate/24x24 -mindepth 1 -maxdepth 1 -type d); do directory=$(basename $dir) if [ -f "mate/22x22/$directory/Makefile.am" ]; \ then cp mate/22x22/$directory/Makefile.am mate/24x24/$directory/Makefile.am sed -i -e 's/-w=22 -h=22/-w=24 -h=24/g' mate/24x24/$directory/Makefile.am dirs+=($directory) fi done ./autogen.sh for dir in ${dirs[@]}; do make -C mate/24x24/$dir clean-png-icons build-png-icons done Change: - @inkscape -z $^ --export-area=A:B:C:D -w=24 -h=24 -e=$@ 1> /dev/null + @inkscape -z $^ --export-area=A-1:B-1:C+1:D+1 -w=24 -h=24 -e=$@ 1> /dev/null
Diffstat (limited to 'mate/24x24/categories/Makefile.am')
-rw-r--r--mate/24x24/categories/Makefile.am36
1 files changed, 18 insertions, 18 deletions
diff --git a/mate/24x24/categories/Makefile.am b/mate/24x24/categories/Makefile.am
index cea5caf..9432600 100644
--- a/mate/24x24/categories/Makefile.am
+++ b/mate/24x24/categories/Makefile.am
@@ -23,92 +23,92 @@ png_icons = \
applications-accessories.png: ../../../src/applications-accessories.svg
@echo " "$@
- @inkscape -z $^ --export-area=302:140:334:172 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-development.png: ../../../src/applications-development.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:101:326:125 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-engineering.png: ../../../src/applications-engineering.svg
@echo " "$@
- @inkscape -z $^ --export-area=304:142:336:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-games.png: ../../../src/applications-games.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=301:101:325:125 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-graphics.png: ../../../src/applications-graphics.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-internet.png: ../../../src/applications-internet.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-multimedia.png: ../../../src/applications-multimedia.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-office.png: ../../../src/applications-office.svg
@echo " "$@
- @inkscape -z $^ --export-area=302:142:334:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=301:100:325:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-other.png: ../../../src/applications-other.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-science.png: ../../../src/applications-science.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-system.png: ../../../src/applications-system.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
applications-utilities.png: ../../../src/applications-utilities.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
preferences-desktop.png: ../../../src/preferences-desktop.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
preferences-desktop-peripherals.png: ../../../src/preferences-desktop-peripherals.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
preferences-desktop-personal.png: ../../../src/preferences-desktop-personal.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
preferences-other.png: ../../../src/preferences-other.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
preferences-system.png: ../../../src/preferences-system.svg
@echo " "$@
- @inkscape -z $^ --export-area=303:142:335:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:100:326:124 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
preferences-system-network.png: ../../../src/computers.svg
@echo " "$@
- @inkscape -z $^ --export-area=302:142:334:174 -w=24 -h=24 -e=$@ 1> /dev/null
+ @inkscape -z $^ --export-area=302:101:326:125 -w=24 -h=24 -e=$@ 1> /dev/null
@mogrify -quiet -strip $@
.PHONY: build-png-icons-local clean-png-icons-local