summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <[email protected]>2018-01-18 04:06:28 +0100
committerMartin Wimpress <[email protected]>2018-01-18 03:06:28 +0000
commit9d6ee461f95e059a42aea9392c37f5a752e9be3d (patch)
tree4ab51362e50400e1f8e533de40d0e139e26be2fc /src/Makefile.am
parent9ae2153657e2aee44fa6c6a70c9f3c4693a3ea20 (diff)
downloadmate-indicator-applet-9d6ee461f95e059a42aea9392c37f5a752e9be3d.tar.bz2
mate-indicator-applet-9d6ee461f95e059a42aea9392c37f5a752e9be3d.tar.xz
Support building against Ayatana Indicators and Ubuntu Indicators alike. (#24)
* If only Ayatana Indicators are present in the build env, build against them. * If only Ubuntu Indicators are present in the build env, build against them. * If both Indicator implementations are present in the build env, then we build against Ayatana Indicators. A build against this or that implementation can be enforced by configure options (--with-ayatana-indicators=yes or --with-ubuntu-indicators=yes). * If either implementation is present, but the other -with-*-indicator configure option is given, an error is thrown at configure time. * No Indicator implementation present in the build env, of course, also throws an error at configure time.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 63458e0..e60f286 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,16 @@
+if WITH_AYATANA_INDICATOR
+INDICATOR_CFLAGS = $(AYATANA_INDICATOR_CFLAGS) \
+ $(AYATANA_INDICATOR_NG_CFLAGS)
+INDICATOR_LIBS = $(AYATANA_INDICATOR_LIBS) \
+ $(AYATANA_INDICATOR_NG_LIBS)
+endif
+
+if WITH_UBUNTU_INDICATOR
+INDICATOR_CFLAGS = $(UBUNTU_INDICATOR_CFLAGS) \
+ $(UBUNTU_INDICATOR_NG_CFLAGS)
+INDICATOR_LIBS = $(UBUNTU_INDICATOR_LIBS) \
+ $(UBUNTU_INDICATOR_NG_LIBS)
+endif
libexec_PROGRAMS = \
mate-indicator-applet \