summaryrefslogtreecommitdiff
path: root/distro/linuxmint/debian
diff options
context:
space:
mode:
Diffstat (limited to 'distro/linuxmint/debian')
-rw-r--r--distro/linuxmint/debian/changelog6
-rw-r--r--distro/linuxmint/debian/compat1
-rw-r--r--distro/linuxmint/debian/control11
-rw-r--r--distro/linuxmint/debian/copyright9
-rw-r--r--distro/linuxmint/debian/dirs0
-rwxr-xr-xdistro/linuxmint/debian/rules88
6 files changed, 115 insertions, 0 deletions
diff --git a/distro/linuxmint/debian/changelog b/distro/linuxmint/debian/changelog
new file mode 100644
index 0000000..3dfc133
--- /dev/null
+++ b/distro/linuxmint/debian/changelog
@@ -0,0 +1,6 @@
+mate-indicator-applet (1.0) lisa; urgency=low
+
+ * Initial release
+
+ -- Clement Lefebvre <[email protected]> Tue, 18 Oct 2011 10:57:00 +0000
+
diff --git a/distro/linuxmint/debian/compat b/distro/linuxmint/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/distro/linuxmint/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/distro/linuxmint/debian/control b/distro/linuxmint/debian/control
new file mode 100644
index 0000000..2e37677
--- /dev/null
+++ b/distro/linuxmint/debian/control
@@ -0,0 +1,11 @@
+Source: mate-indicator-applet
+Section: admin
+Priority: optional
+Maintainer: Clement Lefebvre <[email protected]>
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
+
+Package: mate-indicator-applet
+Architecture: any
+Description: Mate Indicator Applet
+ An applet for indicators in MATE
diff --git a/distro/linuxmint/debian/copyright b/distro/linuxmint/debian/copyright
new file mode 100644
index 0000000..1f5c642
--- /dev/null
+++ b/distro/linuxmint/debian/copyright
@@ -0,0 +1,9 @@
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License version 3 as published by
+ the Free Software Foundation.
+
+The Debian packaging is (C) 2011, Clement Lefebvre <[email protected]> and
+is licensed under the GPLv3, see above.
diff --git a/distro/linuxmint/debian/dirs b/distro/linuxmint/debian/dirs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/distro/linuxmint/debian/dirs
diff --git a/distro/linuxmint/debian/rules b/distro/linuxmint/debian/rules
new file mode 100755
index 0000000..d4c9e55
--- /dev/null
+++ b/distro/linuxmint/debian/rules
@@ -0,0 +1,88 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ mkdir -p $(CURDIR)/debian/mate-indicator-applet
+ cp -r $(CURDIR)/pkg-content/* $(CURDIR)/debian/mate-indicator-applet/
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+# dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure