summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-28 17:28:03 +0800
committerraveit65 <[email protected]>2019-11-09 15:00:24 +0100
commitc16dd6cc8260871d510b1d2ca27c5f5bbc3cb87f (patch)
tree1c81348276dcb5d1427ab40fa1fa15ee7a4c8ceb /data/Makefile.am
parent5ee13d9ee7b843608e0f126c69f63750bc607d61 (diff)
downloadmate-media-c16dd6cc8260871d510b1d2ca27c5f5bbc3cb87f.tar.bz2
mate-media-c16dd6cc8260871d510b1d2ca27c5f5bbc3cb87f.tar.xz
migrate from intltools to gettext
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index fdcfcfc..1e81381 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -5,18 +5,21 @@ SUBDIRS = \
sounds \
$(NULL)
-@INTLTOOL_DESKTOP_RULE@
if ENABLE_STATUSICON
autostartdir = $(sysconfdir)/xdg/autostart
endif
autostart_in_files = mate-volume-control-status-icon.desktop.in
if ENABLE_STATUSICON
autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+$(autostart_DATA): $(autostart_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
endif
appsdir = $(datadir)/applications
apps_in_files = mate-volume-control.desktop.in
apps_DATA = $(apps_in_files:.desktop.in=.desktop)
+$(apps_DATA): $(apps_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
EXTRA_DIST = \
$(autostart_in_files) \