summaryrefslogtreecommitdiff
path: root/grecord/src/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-11 13:11:15 +0100
committerStefano Karapetsas <[email protected]>2011-12-11 13:11:15 +0100
commit4ee2559eaaf2a94ac26c265517e9604a72729360 (patch)
treef24e3e3294c2b75819755289e592bf2e28e668c4 /grecord/src/Makefile.am
downloadmate-media-4ee2559eaaf2a94ac26c265517e9604a72729360.tar.bz2
mate-media-4ee2559eaaf2a94ac26c265517e9604a72729360.tar.xz
moved from Mate-Extra
Diffstat (limited to 'grecord/src/Makefile.am')
-rw-r--r--grecord/src/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/grecord/src/Makefile.am b/grecord/src/Makefile.am
new file mode 100644
index 0000000..58800fa
--- /dev/null
+++ b/grecord/src/Makefile.am
@@ -0,0 +1,30 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = \
+ -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/grecord/src/recent-files/ \
+ $(GSR_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ -DDATADIR=\""$(datadir)"\" \
+ -DGSR_DATADIR=\""$(datadir)/mate-sound-recorder"\" \
+ -DGSR_UIDIR=\""$(datadir)/mate-sound-recorder/ui/"\"
+
+bin_PROGRAMS = mate-sound-recorder
+
+mate_sound_recorder_SOURCES = \
+ mate-recorder.c \
+ gsr-window.c \
+ gsr-window.h
+
+uidir = $(datadir)/mate-sound-recorder/ui
+ui_DATA = ui.xml
+
+EXTRA_DIST = $(ui_DATA)
+
+mate_sound_recorder_LDADD = \
+ -lm \
+ $(GSR_LIBS) -lgstinterfaces-@GST_MAJORMINOR@ \
+ $(top_builddir)/profiles/libmate-media-profiles.la
+
+-include $(top_srcdir)/git.mk