summaryrefslogtreecommitdiff
path: root/gst-mixer-applet/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-12-08 22:18:30 +0100
committerStefano Karapetsas <[email protected]>2012-12-08 22:18:30 +0100
commit4cf8fbb6f138203019c67df2db9b48f2b02cae79 (patch)
treec787d84646619b59c88fa212004e507b74a47185 /gst-mixer-applet/Makefile.am
parente9711267ec88b5e3510f1b59796dc155ed22b156 (diff)
downloadmate-media-4cf8fbb6f138203019c67df2db9b48f2b02cae79.tar.bz2
mate-media-4cf8fbb6f138203019c67df2db9b48f2b02cae79.tar.xz
add gst-mixer-applet (moved from mate-applets package)
it will builds only if gstreamer is enabled
Diffstat (limited to 'gst-mixer-applet/Makefile.am')
-rw-r--r--gst-mixer-applet/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/gst-mixer-applet/Makefile.am b/gst-mixer-applet/Makefile.am
new file mode 100644
index 0000000..53652b8
--- /dev/null
+++ b/gst-mixer-applet/Makefile.am
@@ -0,0 +1,68 @@
+SUBDIRS = docs
+
+AM_CPPFLAGS = -I. -I$(srcdir) \
+ -DMIXER_MENU_UI_DIR=\""$(uidir)"\" \
+ $(MIXERAPPLET_CFLAGS) \
+ $(MATE_APPLETS4_CFLAGS) \
+ $(MATEDESKTOP_CFLAGS)
+
+libexec_PROGRAMS = mixer_applet2
+
+mixer_applet2_SOURCES = \
+ applet.c \
+ dock.c \
+ load.c \
+ preferences.c
+
+noinst_HEADERS = \
+ applet.h \
+ dock.h \
+ keys.h \
+ preferences.h
+
+mixer_applet2_LDADD = \
+ $(MIXERAPPLET_LIBS) \
+ $(MATE_APPLETS4_LIBS) \
+ $(MATEDESKTOP_LIBS) \
+ -lm
+
+appletdir = $(datadir)/mate-panel/applets
+applet_in_files = org.mate.applets.MixerApplet.mate-panel-applet.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+
+$(applet_in_files): $(applet_in_files).in Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
+
+%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.MixerAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.MixerAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ $< > $@
+
+uidir = $(datadir)/mate-2.0/ui
+ui_DATA = mixer-applet-menu.xml
+
+@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_SCHEMAS = org.mate.panel.applet.mixer.gschema.xml
+@GSETTINGS_RULES@
+
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
+
+EXTRA_DIST = \
+ org.mate.applets.MixerApplet.mate-panel-applet.in.in \
+ $(service_in_files) \
+ $(ui_DATA) \
+ $(gsettings_SCHEMAS_in_in)
+
+CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS) *.gschema.valid
+
+-include $(top_srcdir)/git.mk