summaryrefslogtreecommitdiff
path: root/profiles/glade/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-11 13:11:15 +0100
committerStefano Karapetsas <[email protected]>2011-12-11 13:11:15 +0100
commit4ee2559eaaf2a94ac26c265517e9604a72729360 (patch)
treef24e3e3294c2b75819755289e592bf2e28e668c4 /profiles/glade/Makefile.am
downloadmate-media-4ee2559eaaf2a94ac26c265517e9604a72729360.tar.bz2
mate-media-4ee2559eaaf2a94ac26c265517e9604a72729360.tar.xz
moved from Mate-Extra
Diffstat (limited to 'profiles/glade/Makefile.am')
-rw-r--r--profiles/glade/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/profiles/glade/Makefile.am b/profiles/glade/Makefile.am
new file mode 100644
index 0000000..344d160
--- /dev/null
+++ b/profiles/glade/Makefile.am
@@ -0,0 +1,26 @@
+# this is provided for editing mate-media UI files, not for any other
+# purposes
+
+glademoduledir = @GLADEUI_MODULE_DIR@
+glademodule_LTLIBRARIES = libmate-media-profiles.la
+
+defines = \
+ -DG_LOG_DOMAIN=\"mate-media-profiles\" \
+ -DMATELOCALEDIR=\""$(prefix)/${DATADIRNAME}/locale"\" \
+ $(DISABLE_DEPRECATED)
+
+libmate_media_profiles_la_SOURCES = mate-media-profiles-catalog.c
+libmate_media_profiles_la_CFLAGS = $(GMP_CFLAGS) $(GLADEUI_CFLAGS) $(defines) -I$(top_srcdir)
+libmate_media_profiles_la_LIBADD = $(GMP_LIBS) $(GLADEUI_LIBS) $(top_builddir)/profiles/libmate-media-profiles.la
+libmate_media_profiles_la_LDFLAGS = -export-dynamic -module -avoid-version -no-undefined
+
+gladecatalogdir = @GLADEUI_CATALOG_DIR@
+gladecatalog_DATA = mate-media-profiles.xml
+
+check-catalog:
+ xmllint --dtdvalid glade-catalog.dtd --noout $(gladecatalog_DATA)
+
+EXTRA_DIST = \
+ $(gladecatalog_DATA)
+
+-include $(top_srcdir)/git.mk