summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-07-04 18:01:12 +0200
committerStefano Karapetsas <[email protected]>2012-07-04 18:01:12 +0200
commite48fc61bf4cf43a90b7ddf16e3cbb3b247333c89 (patch)
tree15722913e64320b18a09b2452d0a382ebeb953e9 /Makefile.am
downloadmate-netbook-e48fc61bf4cf43a90b7ddf16e3cbb3b247333c89.tar.bz2
mate-netbook-e48fc61bf4cf43a90b7ddf16e3cbb3b247333c89.tar.xz
Initial release
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0e846ca
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = po maximus mate-window-picker-applet
+
+EXTRA_DIST = intltool-merge.in intltool-extract.in intltool-update.in
+DISTCLEANFILES = intltool-merge intltool-update intltool-extract
+
+MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp install-sh ltmain.sh Makefile.in missing
+
+dist-hook:
+ @if test -d "$(srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog >&2; \
+ fi