summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-10-22 08:11:59 -0700
committerStefano Karapetsas <[email protected]>2013-10-22 08:11:59 -0700
commit9d9aa2b9986edd94a3b72a593be7fd588fc031a0 (patch)
tree8f65ce2c70943e21e7a03784466e7a4f3bfae1be /configure.ac
parent0656ca9fb350ebcf05d205dc861cacc875067dd7 (diff)
parent14d28b255c8e9fc26cc6e6bf0fc96d938f88fa27 (diff)
downloadmate-notification-daemon-9d9aa2b9986edd94a3b72a593be7fd588fc031a0.tar.bz2
mate-notification-daemon-9d9aa2b9986edd94a3b72a593be7fd588fc031a0.tar.xz
Merge pull request #22 from infirit/master
New option to disable icon cache generation and small autofoo fixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a622f23..c40cc48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,6 +243,16 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
else
AC_MSG_RESULT(no)
fi
+
+dnl ---------------------------------------------------------------------------
+dnl Enabel/disable icon cache generation
+dnl ---------------------------------------------------------------------------
+AC_ARG_ENABLE(icon-update, AC_HELP_STRING([--disable-icon-update],
+ [Disable icon cache update]))
+if (test "$enable_icon_update" != no); then
+ AC_PATH_PROG(UPDATE_ICON_CACHE, [gtk-update-icon-cache])
+fi
+AM_CONDITIONAL([ICON_UPDATE], [test -n "$UPDATE_ICON_CACHE"])
AM_CFLAGS="$AM_CFLAGS $WARN_CFLAGS $WARNINGCFLAGS"
AM_CXXFLAGS="$AM_CXXFLAGS $WARN_CXXFLAGS"