summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-10-10 22:06:59 +0200
committerraveit65 <[email protected]>2019-10-20 23:42:09 +0200
commit9f5e0db85fe80f97c38576922c2748eb94b46a4b (patch)
treedcf40e987e0d5d34a7e8814b941ab1d01428919c /configure.ac
parenta4054692c35b5e1ed584177de94baa1aca80886d (diff)
downloadmate-notification-daemon-9f5e0db85fe80f97c38576922c2748eb94b46a4b.tar.bz2
mate-notification-daemon-9f5e0db85fe80f97c38576922c2748eb94b46a4b.tar.xz
Use gresource for mate-notification-properties.ui
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1313e11..06a22c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,24 @@ AC_DEFINE([GETTEXT_PACKAGE], [PACKAGE_TARNAME], [Define to the gettext package n
dnl ---------------------------------------------------------------------------
+dnl GLIB_COMPILE_RESOURCES
+dnl ---------------------------------------------------------------------------
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+dnl ---------------------------------------------------------------------------
+dnl XMLLINT
+dnl ---------------------------------------------------------------------------
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
+dnl ---------------------------------------------------------------------------
dnl Requirements for the themes
dnl ---------------------------------------------------------------------------