summaryrefslogtreecommitdiff
path: root/src/capplet/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 22:49:12 -0300
committerPerberos <[email protected]>2011-12-01 22:49:12 -0300
commit781b0ff3f74abd6f5353b6d08763bbba93f2f21c (patch)
tree20c130b413586219356ec360efb5918a498cee69 /src/capplet/Makefile.am
downloadmate-notification-daemon-781b0ff3f74abd6f5353b6d08763bbba93f2f21c.tar.bz2
mate-notification-daemon-781b0ff3f74abd6f5353b6d08763bbba93f2f21c.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'src/capplet/Makefile.am')
-rw-r--r--src/capplet/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/capplet/Makefile.am b/src/capplet/Makefile.am
new file mode 100644
index 0000000..c053d80
--- /dev/null
+++ b/src/capplet/Makefile.am
@@ -0,0 +1,26 @@
+bin_PROGRAMS = mate-notification-properties
+
+@INTLTOOL_DESKTOP_RULE@
+
+mate_notification_properties_LDADD = $(NOTIFICATION_CAPPLET_LIBS)
+mate_notification_properties_SOURCES = mate-notification-properties.c
+
+uidir = $(datadir)/mate-notification-daemon
+ui_DATA = mate-notification-properties.ui
+
+desktopdir = $(datadir)/applications
+desktop_in_files = mate-notification-properties.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/src/daemon \
+ $(NOTIFICATION_CAPPLET_CFLAGS) \
+ -DENGINES_DIR=\"$(libdir)/mate-notification-daemon/engines\" \
+ -DNOTIFICATION_LOCALEDIR=\"$(datadir)/locale\" \
+ -DNOTIFICATION_UIDIR=\"$(datadir)/mate-notification-daemon\"
+
+CLEANFILES = $(desktop_DATA)
+EXTRA_DIST = $(ui_DATA) $(pixmap_DATA) $(desktop_in_files)
+
+-include $(top_srcdir)/git.mk