summaryrefslogtreecommitdiff
path: root/src/capplet/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-11-17 01:27:34 +0100
committerraveit65 <[email protected]>2020-11-26 11:50:18 +0100
commitc1dd04d294e329da95c515d7f5a9ac7a00d269cc (patch)
tree2a129f163e6c3302d0fa5dfdf96bdee0de8a2e46 /src/capplet/Makefile.am
parentb704b0e30d2ad7672c3fa86c02f3f311327fd66a (diff)
downloadmate-notification-daemon-c1dd04d294e329da95c515d7f5a9ac7a00d269cc.tar.bz2
mate-notification-daemon-c1dd04d294e329da95c515d7f5a9ac7a00d269cc.tar.xz
Add Do Not Disturb Applet
Diffstat (limited to 'src/capplet/Makefile.am')
-rw-r--r--src/capplet/Makefile.am84
1 files changed, 65 insertions, 19 deletions
diff --git a/src/capplet/Makefile.am b/src/capplet/Makefile.am
index 509133d..2e27e00 100644
--- a/src/capplet/Makefile.am
+++ b/src/capplet/Makefile.am
@@ -1,30 +1,76 @@
+define generate_resources_deps
+ $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/$(1))
+endef
+
bin_PROGRAMS = mate-notification-properties
+libexec_PROGRAMS = mate-notification-applet
-BUILT_SOURCES = mate-notification-properties-resources.h mate-notification-properties-resources.c
+NULL =
-mate_notification_properties_LDADD = $(NOTIFICATION_CAPPLET_LIBS)
-mate_notification_properties_SOURCES = $(BUILT_SOURCES) mate-notification-properties.c
-mate_notification_properties_CFLAGS = $(WARN_CFLAGS)
+mate_notification_properties_CFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/src/daemon \
+ $(NOTIFICATION_CAPPLET_CFLAGS) \
+ -DENGINES_DIR=\"$(libdir)/mate-notification-daemon/engines\" \
+ -DNOTIFICATION_LOCALEDIR=\"$(datadir)/locale\" \
+ $(WARN_CFLAGS) \
+ $(NULL)
-mate-notification-properties-resources.h mate-notification-properties-resources.c: org.mate.notifications.properties.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.notifications.properties.gresource.xml)
- $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name notification_properties $<
+mate_notification_properties_LDADD = \
+ $(NOTIFICATION_CAPPLET_LIBS) \
+ $(NULL)
-desktopdir = $(datadir)/applications
-desktop_in_files = mate-notification-properties.desktop.in
-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-$(desktop_DATA): $(desktop_in_files)
- $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+mate_notification_properties_resources_xml = org.mate.notifications.properties.gresource.xml
+mate_notification_properties_resources_deps = $(call generate_resources_deps $(mate_notification_properties_resources_xml))
+mate_notification_properties_resources_files = mate-notification-properties-resources.h mate-notification-properties-resources.c
+$(mate_notification_properties_resources_files): $(mate_notification_properties_resources_xml) Makefile $(mate_notification_properties_resources_deps)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) $< \
+ --target $@ --sourcedir $(srcdir) --generate --c-name notification_properties
+mate_notification_properties_SOURCES = \
+ $(mate_notification_properties_resources_files) \
+ mate-notification-properties.c \
+ $(NULL)
man_MANS = mate-notification-properties.1
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/src/daemon \
- $(NOTIFICATION_CAPPLET_CFLAGS) \
- -DENGINES_DIR=\"$(libdir)/mate-notification-daemon/engines\" \
- -DNOTIFICATION_LOCALEDIR=\"$(datadir)/locale\"
+mate_notification_applet_CFLAGS = \
+ $(NOTIFICATION_APPLET_CFLAGS) \
+ -DMATELOCALEDIR=\"$(datadir)/locale\" \
+ -DRESOURCE_PATH=\""/org/mate/panel/applet/notifications/"\" \
+ $(WARN_CFLAGS) \
+ $(NULL)
+
+mate_notification_applet_LDADD = \
+ $(NOTIFICATION_APPLET_LIBS) \
+ $(NULL)
+
+mate_notification_applet_resources_xml = org.mate.panel.applet.notifications.gresource.xml
+mate_notification_applet_resources_deps = $(call generate_resources_deps $(mate_notification_applet_resources_xml))
+mate_notification_applet_resources_files = mate-notification-applet-resources.h mate-notification-applet-resources.c
+$(mate_notification_applet_resources_files): $(mate_notification_applet_resources_xml) Makefile $(mate_notification_applet_resources_deps)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) $< \
+ --target $@ --sourcedir $(srcdir) --generate --c-name notification_applet
+mate_notification_applet_SOURCES = \
+ $(mate_notification_applet_resources_files) \
+ mate-notification-applet.c \
+ $(NULL)
+
+BUILT_SOURCES = \
+ $(mate_notification_properties_resources_files) \
+ $(mate_notification_applet_resources_files) \
+ $(NULL)
+
+CLEANFILES = \
+ $(BUILT_SOURCES) \
+ $(NULL)
-CLEANFILES = $(desktop_DATA) $(BUILT_SOURCES)
-EXTRA_DIST = mate-notification-properties.ui $(pixmap_DATA) $(desktop_in_files) $(man_MANS) org.mate.notifications.properties.gresource.xml
+EXTRA_DIST = \
+ $(man_MANS) \
+ $(pixmap_DATA) \
+ $(mate_notification_applet_resources_xml) \
+ $(mate_notification_properties_resources_xml) \
+ mate-notification-applet-menu.xml \
+ mate-notification-properties.ui \
+ $(NULL)
-include $(top_srcdir)/git.mk