summaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 22:49:12 -0300
committerPerberos <[email protected]>2011-12-01 22:49:12 -0300
commit781b0ff3f74abd6f5353b6d08763bbba93f2f21c (patch)
tree20c130b413586219356ec360efb5918a498cee69 /src/daemon/Makefile.am
downloadmate-notification-daemon-781b0ff3f74abd6f5353b6d08763bbba93f2f21c.tar.bz2
mate-notification-daemon-781b0ff3f74abd6f5353b6d08763bbba93f2f21c.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
new file mode 100644
index 0000000..4f9471c
--- /dev/null
+++ b/src/daemon/Makefile.am
@@ -0,0 +1,30 @@
+libexec_PROGRAMS = mate-notification-daemon
+
+mate_notification_daemon_SOURCES = \
+ daemon.c \
+ daemon.h \
+ engines.c \
+ engines.h \
+ stack.c \
+ stack.h \
+ sound.c \
+ sound.h
+
+mate_notification_daemon_LDADD = $(NOTIFICATION_DAEMON_LIBS)
+
+BUILT_SOURCES = notificationdaemon-dbus-glue.h
+
+notificationdaemon-dbus-glue.h: notificationdaemon.xml
+ dbus-binding-tool --mode=glib-server --prefix=notification_daemon \
+ $(srcdir)/notificationdaemon.xml > notificationdaemon-dbus-glue.h
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(NOTIFICATION_DAEMON_CFLAGS) \
+ -DENGINES_DIR=\"$(libdir)/mate-notification-daemon/engines\"
+
+EXTRA_DIST = notificationdaemon.xml
+DISTCLEANFILES = \
+ notificationdaemon-dbus-glue.h
+
+-include $(top_srcdir)/git.mk