summaryrefslogtreecommitdiff
path: root/src/themes/nodoka/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-10-10 20:21:39 +0200
committerraveit65 <[email protected]>2019-10-11 17:09:43 +0200
commit1f714672693f637f81ac55cf4f4618c74d10e229 (patch)
tree4b0608984141ac3918fde87e64eea77983a5ff86 /src/themes/nodoka/Makefile.am
parent2aa513e98b1e3ab11a8ed8b3421cc47780f62101 (diff)
downloadmate-notification-daemon-1f714672693f637f81ac55cf4f4618c74d10e229.tar.bz2
mate-notification-daemon-1f714672693f637f81ac55cf4f4618c74d10e229.tar.xz
Use WARN_CFLAGS which are only set with --enable-compiler-warnings
It removes --enable-more-warnings, since it is recommended to use --enable-compile-warnings=maximum It updates configure summary. It removes c++ checks as there is no c++ code.
Diffstat (limited to 'src/themes/nodoka/Makefile.am')
-rw-r--r--src/themes/nodoka/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/themes/nodoka/Makefile.am b/src/themes/nodoka/Makefile.am
index 38b797c..b49bdcf 100644
--- a/src/themes/nodoka/Makefile.am
+++ b/src/themes/nodoka/Makefile.am
@@ -4,6 +4,6 @@ enginedir = $(libdir)/mate-notification-daemon/engines
engine_LTLIBRARIES = libnodoka.la
libnodoka_la_SOURCES = nodoka-theme.c
-
+libnodoka_la_CFLAGS = $(WARN_CFLAGS)
libnodoka_la_LDFLAGS = -module -avoid-version -no-undefined
libnodoka_la_LIBADD = $(THEME_LIBS)