summaryrefslogtreecommitdiff
path: root/src/themes/slider/Makefile.am
diff options
context:
space:
mode:
authorYaakov Selkowitz <[email protected]>2012-12-25 21:50:14 -0600
committerStefano Karapetsas <[email protected]>2013-01-04 17:29:50 +0100
commit61d109a6e5794cf393d1f9d5bebda10f8efce902 (patch)
tree308bbb77ef752ad600020bb77a59d542d854f26b /src/themes/slider/Makefile.am
parent2f0f21bde5e00fc0abb3379ffb9f23574e9508ad (diff)
downloadmate-notification-daemon-61d109a6e5794cf393d1f9d5bebda10f8efce902.tar.bz2
mate-notification-daemon-61d109a6e5794cf393d1f9d5bebda10f8efce902.tar.xz
Fix engine loading portability
Use GModule APIs for determining engine filenames. Also, link with the -no-undefined flag, required on PE platforms.
Diffstat (limited to 'src/themes/slider/Makefile.am')
-rw-r--r--src/themes/slider/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/themes/slider/Makefile.am b/src/themes/slider/Makefile.am
index a94ceaa..46dcdd2 100644
--- a/src/themes/slider/Makefile.am
+++ b/src/themes/slider/Makefile.am
@@ -7,7 +7,7 @@ AM_CPPFLAGS = $(THEME_CFLAGS)
libslider_la_SOURCES = theme.c
-libslider_la_LDFLAGS = -module -avoid-version
+libslider_la_LDFLAGS = -module -avoid-version -no-undefined
libslider_la_LIBADD = \
$(THEME_LIBS) \
$(NULL)