summaryrefslogtreecommitdiff
path: root/src/themes/standard/Makefile.am
diff options
context:
space:
mode:
authorYaakov Selkowitz <[email protected]>2012-12-25 21:50:14 -0600
committerStefano Karapetsas <[email protected]>2013-01-04 17:29:50 +0100
commit61d109a6e5794cf393d1f9d5bebda10f8efce902 (patch)
tree308bbb77ef752ad600020bb77a59d542d854f26b /src/themes/standard/Makefile.am
parent2f0f21bde5e00fc0abb3379ffb9f23574e9508ad (diff)
downloadmate-notification-daemon-61d109a6e5794cf393d1f9d5bebda10f8efce902.tar.bz2
mate-notification-daemon-61d109a6e5794cf393d1f9d5bebda10f8efce902.tar.xz
Fix engine loading portability
Use GModule APIs for determining engine filenames. Also, link with the -no-undefined flag, required on PE platforms.
Diffstat (limited to 'src/themes/standard/Makefile.am')
-rw-r--r--src/themes/standard/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/themes/standard/Makefile.am b/src/themes/standard/Makefile.am
index 9d6a6ae..d5b4a2a 100644
--- a/src/themes/standard/Makefile.am
+++ b/src/themes/standard/Makefile.am
@@ -3,7 +3,7 @@ enginedir = $(libdir)/mate-notification-daemon/engines
engine_LTLIBRARIES = libstandard.la
libstandard_la_SOURCES = theme.c
-libstandard_la_LDFLAGS = -module -avoid-version
+libstandard_la_LDFLAGS = -module -avoid-version -no-undefined
libstandard_la_LIBADD = $(NOTIFICATION_DAEMON_LIBS)
INCLUDES = $(NOTIFICATION_DAEMON_CFLAGS)