summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 39d5d8c..5f88508 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,7 +41,7 @@ AC_DEFINE_UNQUOTED(NOTIFICATION_DAEMON_VERSION, "$NOTIFICATION_DAEMON_VERSION",
dnl ################################################################
dnl # Initialize automake
dnl ################################################################
-AM_INIT_AUTOMAKE([1.10 no-dist-gzip dist-bzip2])
+AM_INIT_AUTOMAKE([1.10 no-dist-gzip dist-xz foreign])
AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -243,6 +243,16 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
else
AC_MSG_RESULT(no)
fi
+
+dnl ---------------------------------------------------------------------------
+dnl Enabel/disable icon cache generation
+dnl ---------------------------------------------------------------------------
+AC_ARG_ENABLE(icon-update, AC_HELP_STRING([--disable-icon-update],
+ [Disable icon cache update]))
+if (test "$enable_icon_update" != no); then
+ AC_PATH_PROG(UPDATE_ICON_CACHE, [gtk-update-icon-cache])
+fi
+AM_CONDITIONAL([ICON_UPDATE], [test -n "$UPDATE_ICON_CACHE"])
AM_CFLAGS="$AM_CFLAGS $WARN_CFLAGS $WARNINGCFLAGS"
AM_CXXFLAGS="$AM_CXXFLAGS $WARN_CXXFLAGS"