summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 39d5d8c..e6760de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,6 +243,16 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
else
AC_MSG_RESULT(no)
fi
+
+dnl ---------------------------------------------------------------------------
+dnl Enabel/disable icon cache generation
+dnl ---------------------------------------------------------------------------
+AC_ARG_ENABLE(icon-update, AC_HELP_STRING([--disable-icon-update],
+ [Disable icon cache update]))
+if (test "$enable_icon_update" != no); then
+ AC_PATH_PROG(UPDATE_ICON_CACHE, [gtk-update-icon-cache])
+fi
+AM_CONDITIONAL([ICON_UPDATE], [test -n "$UPDATE_ICON_CACHE"])
AM_CFLAGS="$AM_CFLAGS $WARN_CFLAGS $WARNINGCFLAGS"
AM_CXXFLAGS="$AM_CXXFLAGS $WARN_CXXFLAGS"