summaryrefslogtreecommitdiff
path: root/applets/notification_area/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-30 20:33:54 +0800
committerraveit65 <[email protected]>2019-11-11 23:18:35 +0100
commitf5354df76377627dde56b079c9328b46865033d2 (patch)
treee49277e64f87be43bbb3ea1008f3f56916f743e0 /applets/notification_area/Makefile.am
parent1614cec077ab369640b24ff73045bf470ca93683 (diff)
downloadmate-panel-f5354df76377627dde56b079c9328b46865033d2.tar.bz2
mate-panel-f5354df76377627dde56b079c9328b46865033d2.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'applets/notification_area/Makefile.am')
-rw-r--r--applets/notification_area/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/applets/notification_area/Makefile.am b/applets/notification_area/Makefile.am
index 57ee0a3b..f7b68110 100644
--- a/applets/notification_area/Makefile.am
+++ b/applets/notification_area/Makefile.am
@@ -70,8 +70,11 @@ notification_area_applet_CFLAGS = $(AM_CFLAGS)
endif
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.panel.NotificationAreaApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.panel.NotificationAreaApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
+
+$(applet_DATA): $(applet_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword Name --keyword Description --template $< -d $(top_srcdir)/po -o $@
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
@@ -80,8 +83,6 @@ $(applet_in_files): $(applet_in_files).in Makefile
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
-@PANEL_INTLTOOL_MATE_PANEL_APPLET_RULE@
-
if !NOTIFICATION_AREA_INPROCESS
servicedir = $(datadir)/dbus-1/services
service_in_files = org.mate.panel.applet.NotificationAreaAppletFactory.service.in
@@ -110,11 +111,10 @@ BUILT_SOURCES = \
na-resources.c \
na-resources.h
-@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
EXTRA_DIST = \
- org.mate.panel.NotificationAreaApplet.mate-panel-applet.in.in \
+ org.mate.panel.NotificationAreaApplet.mate-panel-applet.desktop.in.in \
$(notification_area_gschemas_in) \
$(ui_FILES) \
na.gresource.xml \
@@ -122,7 +122,7 @@ EXTRA_DIST = \
CLEANFILES = \
$(applet_DATA) \
- $(applet_DATA).in \
+ $(applet_in_files) \
$(service_DATA) \
$(gsettings_SCHEMAS)