summaryrefslogtreecommitdiff
path: root/applets/wncklet/Makefile.am
diff options
context:
space:
mode:
authorWilliam Wold <[email protected]>2020-09-30 16:12:15 -0700
committerraveit65 <[email protected]>2020-10-21 20:35:15 +0200
commitea5f814e611094cca992afb6d54b49d178bce959 (patch)
tree9da4238f70e5f889392a2e8b7592e74e3bd409a1 /applets/wncklet/Makefile.am
parent2f5ab12d358be4ab3e8e8ba42dcd0a7a6a84de64 (diff)
downloadmate-panel-ea5f814e611094cca992afb6d54b49d178bce959.tar.bz2
mate-panel-ea5f814e611094cca992afb6d54b49d178bce959.tar.xz
Window list Wayland support
Diffstat (limited to 'applets/wncklet/Makefile.am')
-rw-r--r--applets/wncklet/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/applets/wncklet/Makefile.am b/applets/wncklet/Makefile.am
index b933f81b..e6844963 100644
--- a/applets/wncklet/Makefile.am
+++ b/applets/wncklet/Makefile.am
@@ -23,6 +23,14 @@ WNCKLET_SOURCES = \
showdesktop.h \
$(BUILT_SOURCES)
+if ENABLE_WAYLAND
+WNCKLET_SOURCES += \
+ wayland-backend.c \
+ wayland-backend.h \
+ wayland-protocol/wlr-foreign-toplevel-management-unstable-v1-code.c \
+ wayland-protocol/wlr-foreign-toplevel-management-unstable-v1-client.h
+endif
+
WNCKLET_LDADD = \
../../libmate-panel-applet/libmate-panel-applet-4.la \
$(WNCKLET_LIBS) \