summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2018-04-18 23:50:46 -0400
committermonsta <[email protected]>2018-04-25 17:19:52 +0300
commit4437af31ff82629c18f53f6f4c38430547378af9 (patch)
treea868ecdac5ba9f23c4f95b001608cc38db1b0c52 /data/Makefile.am
parent3a8b1f66d2393a35f40dbcc211d3bf045d563a92 (diff)
downloadmate-panel-4437af31ff82629c18f53f6f4c38430547378af9.tar.bz2
mate-panel-4437af31ff82629c18f53f6f4c38430547378af9.tar.xz
Theme: consistant theming for applet drag handles in all themes
* applet drag-handle: use a symbolic image for the default drag handle image * Use an .svg image with --gtk-recolor (like a symbolic icon), load it from the same directory as the css file so the css parser can find it, and use the theme fg color on it for good contrast * load a css file to use the recolorable image globally for the panel, not for each applet to ensure only one cssprovider is loaded (port of 45b25410cddde852554b3153e81ad59a5e6722ad to 1.18 branch, limiting it to GTK+ 3.20/22)
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 0f64e315..dc8660bf 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -7,6 +7,11 @@ layout_DATA = \
opensuse.layout \
ubuntu.layout
+matepaneldir = $(datadir)/mate-panel
+matepanel_DATA = \
+ mate-panel.css \
+ panel-grid-symbolic.svg
+
@INTLTOOL_XML_NOMERGE_RULE@
gsettings_ENUM_NAMESPACE = org.mate.panel
@@ -27,6 +32,7 @@ gsettings_SCHEMAS = $(panel_gschemas_in:.xml.in=.xml)
EXTRA_DIST = \
$(panel_gschemas_in) \
- $(layout_DATA)
+ $(layout_DATA) \
+ $(matepanel_DATA)
CLEANFILES = $(gsettings_SCHEMAS)