summaryrefslogtreecommitdiff
path: root/applets/notification_area/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/notification_area/Makefile.am')
-rw-r--r--applets/notification_area/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/applets/notification_area/Makefile.am b/applets/notification_area/Makefile.am
index b584f084..67d4f8c6 100644
--- a/applets/notification_area/Makefile.am
+++ b/applets/notification_area/Makefile.am
@@ -93,6 +93,9 @@ org.mate.panel.applet.NotificationAreaAppletFactory.service: $(service_in_files)
$< > $@
endif
+notification_area_gschemas_in = org.mate.panel.applet.notification-area.gschema.xml.in
+gsettings_SCHEMAS = $(notification_area_gschemas_in:.xml.in=.xml)
+
ui_FILES = \
notification-area-menu.xml
@@ -106,8 +109,12 @@ BUILT_SOURCES = \
na-resources.c \
na-resources.h
+@INTLTOOL_XML_NOMERGE_RULE@
+@GSETTINGS_RULES@
+
EXTRA_DIST = \
org.mate.panel.NotificationAreaApplet.mate-panel-applet.in.in \
+ $(notification_area_gschemas_in) \
$(ui_FILES) \
na.gresource.xml \
$(service_in_files)
@@ -115,6 +122,7 @@ EXTRA_DIST = \
CLEANFILES = \
$(applet_DATA) \
$(applet_DATA).in \
- $(service_DATA)
+ $(service_DATA) \
+ $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk