summaryrefslogtreecommitdiff
path: root/applets/wncklet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/wncklet/Makefile.am')
-rw-r--r--applets/wncklet/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/applets/wncklet/Makefile.am b/applets/wncklet/Makefile.am
index 84682ee9..dc23143f 100644
--- a/applets/wncklet/Makefile.am
+++ b/applets/wncklet/Makefile.am
@@ -90,9 +90,16 @@ BUILT_SOURCES = \
wncklet-resources.c \
wncklet-resources.h
+if HAVE_WINDOW_PREVIEWS
wncklet_gschemas_in = \
org.mate.panel.applet.window-list.gschema.xml.in \
+ org.mate.panel.applet.window-list-previews.gschema.xml.in \
org.mate.panel.applet.workspace-switcher.gschema.xml.in
+else
+wncklet_gschemas_in = \
+ org.mate.panel.applet.window-list.gschema.xml.in \
+ org.mate.panel.applet.workspace-switcher.gschema.xml.in
+endif
gsettings_SCHEMAS = $(wncklet_gschemas_in:.xml.in=.xml)
@INTLTOOL_XML_NOMERGE_RULE@