summaryrefslogtreecommitdiff
path: root/applets/wncklet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/wncklet/Makefile.am')
-rw-r--r--applets/wncklet/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/applets/wncklet/Makefile.am b/applets/wncklet/Makefile.am
index b933f81b..e6844963 100644
--- a/applets/wncklet/Makefile.am
+++ b/applets/wncklet/Makefile.am
@@ -23,6 +23,14 @@ WNCKLET_SOURCES = \
showdesktop.h \
$(BUILT_SOURCES)
+if ENABLE_WAYLAND
+WNCKLET_SOURCES += \
+ wayland-backend.c \
+ wayland-backend.h \
+ wayland-protocol/wlr-foreign-toplevel-management-unstable-v1-code.c \
+ wayland-protocol/wlr-foreign-toplevel-management-unstable-v1-client.h
+endif
+
WNCKLET_LDADD = \
../../libmate-panel-applet/libmate-panel-applet-4.la \
$(WNCKLET_LIBS) \