summaryrefslogtreecommitdiff
path: root/mate-panel/wayland-protocols/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/wayland-protocols/Makefile.am')
-rw-r--r--mate-panel/wayland-protocols/Makefile.am26
1 files changed, 13 insertions, 13 deletions
diff --git a/mate-panel/wayland-protocols/Makefile.am b/mate-panel/wayland-protocols/Makefile.am
index 05ba45c4..f33e7781 100644
--- a/mate-panel/wayland-protocols/Makefile.am
+++ b/mate-panel/wayland-protocols/Makefile.am
@@ -1,23 +1,23 @@
if ENABLE_WAYLAND
-all: wlr-layer-shell-unstable-v1-client-protocol.h wlr-layer-shell-unstable-v1-protocol.c xdg-shell-client-protocol.h xdg-shell-protocol.c
+all: wlr-layer-shell-unstable-v1-client.h wlr-layer-shell-unstable-v1.c xdg-shell-client.h xdg-shell.c
-wlr-layer-shell-unstable-v1-client-protocol.h: wlr-layer-shell-unstable-v1.xml
- wayland-scanner -c client-header wlr-layer-shell-unstable-v1.xml wlr-layer-shell-unstable-v1-client-protocol.h
+wlr-layer-shell-unstable-v1-client.h: wlr-layer-shell-unstable-v1.xml
+ wayland-scanner -c client-header wlr-layer-shell-unstable-v1.xml wlr-layer-shell-unstable-v1-client.h
# 'code' is depricated, and can be replaced with 'private-code' when all platforms have a new enough wayland-scanner
-wlr-layer-shell-unstable-v1-protocol.c: wlr-layer-shell-unstable-v1.xml
- wayland-scanner -c code wlr-layer-shell-unstable-v1.xml wlr-layer-shell-unstable-v1-protocol.c
+wlr-layer-shell-unstable-v1.c: wlr-layer-shell-unstable-v1.xml
+ wayland-scanner -c code wlr-layer-shell-unstable-v1.xml wlr-layer-shell-unstable-v1.c
-xdg-shell-client-protocol.h: xdg-shell.xml
- wayland-scanner -c client-header xdg-shell.xml xdg-shell-client-protocol.h
+xdg-shell-client.h: xdg-shell.xml
+ wayland-scanner -c client-header xdg-shell.xml xdg-shell-client.h
# 'code' is depricated, and can be replaced with 'private-code' when all platforms have a new enough wayland-scanner
-xdg-shell-protocol.c: xdg-shell.xml
- wayland-scanner -c code xdg-shell.xml xdg-shell-protocol.c
+xdg-shell.c: xdg-shell.xml
+ wayland-scanner -c code xdg-shell.xml xdg-shell.c
endif
clean:
- rm -f wlr-layer-shell-unstable-v1-client-protocol.h
- rm -f wlr-layer-shell-unstable-v1-protocol.c
- rm -f xdg-shell-client-protocol.h
- rm -f xdg-shell-protocol.c
+ rm -f wlr-layer-shell-unstable-v1-client.h
+ rm -f wlr-layer-shell-unstable-v1.c
+ rm -f xdg-shell-client.h
+ rm -f xdg-shell.c