summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2017-12-15 18:24:04 +0300
committermonsta <[email protected]>2017-12-15 18:24:04 +0300
commitd87d54b16f4c1fd0ee595be273a56c424eaee694 (patch)
tree50527addeb695aa1ee144c032aa2e16dc83474c5 /configure.ac
parentffce78e71412985205381e76019afb3e5a002758 (diff)
downloadmate-polkit-d87d54b16f4c1fd0ee595be273a56c424eaee694.tar.bz2
mate-polkit-d87d54b16f4c1fd0ee595be273a56c424eaee694.tar.xz
drop polkitgtkmate library and its docs
it contains only PolkitLockButton widget which nobody uses by now and GTK+3 already has GtkLockButton same as done upstream long ago: https://git.gnome.org/browse/PolicyKit-gnome/commit/?id=1340926a935b60b2b605a8d0d9b256e3a83c3d7d https://git.gnome.org/browse/PolicyKit-gnome/commit/?id=b8d700121941bb1f032b95c428d2e52a11c5d330
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 0 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index f8a4d20..cd84953 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,8 +28,6 @@ AC_HEADER_STDC
LT_PREREQ([2.2.6])
LT_INIT
-GTK_DOC_CHECK([1.3])
-
#### gcc warning flags
if test "x$GCC" = "xyes"; then
@@ -172,32 +170,6 @@ AM_CONDITIONAL(HAVE_APPINDICATOR, test "x$enable_appindicator" = "xyes")
AC_SUBST(APPINDICATOR_CFLAGS)
AC_SUBST(APPINDICATOR_LIBS)
-AC_ARG_ENABLE([examples],
- AC_HELP_STRING([--enable-examples], [Build the example programs]),,
- [enable_examples=yes])
-
-AM_CONDITIONAL(BUILD_EXAMPLES, test "x$enable_examples" = "xyes")
-
-# GObject introspection
-#
-AC_ARG_ENABLE([introspection],
- AS_HELP_STRING([--enable-introspection], [enable GObject introspection]),
- [], [enable_introspection=yes])
-if test "x$enable_introspection" = xyes; then
- PKG_CHECK_MODULES([INTROSPECTION], [gobject-introspection-1.0 >= 0.6.2])
- AC_DEFINE([ENABLE_INTROSPECTION], [1], [enable GObject introspection support])
- AC_SUBST([G_IR_SCANNER], [$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)])
- AC_SUBST([G_IR_COMPILER], [$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)])
- AC_SUBST([G_IR_GENERATE], [$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)])
- #AC_SUBST([GIRDIR], [$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)])
- #AC_SUBST([GIRTYPELIBDIR], [$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)])
- GIRDIR=${datadir}/gir-1.0
- GIRTYPELIBDIR=${libdir}/girepository-1.0
- AC_SUBST(GIRDIR)
- AC_SUBST(GIRTYPELIBDIR)
-fi
-AM_CONDITIONAL([ENABLE_INTROSPECTION], [test "x$enable_introspection" = xyes])
-
# ********************
# Internationalisation
# ********************
@@ -214,17 +186,12 @@ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[gettext domain])
AC_SUBST([AM_CPPFLAGS])
AC_SUBST([AM_CFLAGS])
-AC_SUBST([AM_CXXFLAGS])
AC_SUBST([AM_LDFLAGS])
AC_CONFIG_FILES([
Makefile
po/Makefile.in
-polkitgtkmate/Makefile
-polkitgtkmate/polkit-gtk-mate-1.pc
src/Makefile
-docs/version.xml
-docs/Makefile
])
AC_OUTPUT
@@ -249,6 +216,4 @@ echo "
Accountsservice: ${enable_accountsservice}
Application indicator: ${enable_appindicator}
Maintainer mode: ${USE_MAINTAINER_MODE}
- Building api docs: ${enable_gtk_doc}
- GObject Introspection: ${enable_introspection}
"