summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 23:00:56 -0300
committerPerberos <[email protected]>2011-12-01 23:00:56 -0300
commit1c69f467452c8f34d099019d463980ad57811192 (patch)
tree72ab1456032eb3c29f7fe327b5da6ac8e734507a /src/Makefile.am
downloadmate-polkit-1c69f467452c8f34d099019d463980ad57811192.tar.bz2
mate-polkit-1c69f467452c8f34d099019d463980ad57811192.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..58f9507
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,51 @@
+
+FULL_LIBEXECDIR=$(libexecdir)
+
+desktopdir = $(sysconfdir)/xdg/autostart
+desktop_DATA = polkit-mate-authentication-agent-1.desktop
+
+@INTLTOOL_DESKTOP_RULE@
+
+polkit-mate-authentication-agent-1.desktop.in : polkit-mate-authentication-agent-1.desktop.in.in
+ cat polkit-mate-authentication-agent-1.desktop.in.in | sed 's,@FULL_LIBEXECDIR@,$(FULL_LIBEXECDIR),' > $@
+
+libexec_PROGRAMS = polkit-mate-authentication-agent-1
+
+polkit_mate_authentication_agent_1_SOURCES = \
+ polkitmatelistener.h polkitmatelistener.c \
+ polkitmateauthenticator.h polkitmateauthenticator.c \
+ polkitmateauthenticationdialog.h polkitmateauthenticationdialog.c \
+ main.c \
+ $(BUILT_SOURCES)
+
+polkit_mate_authentication_agent_1_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"polkit-mate-1\" \
+ -DDATADIR=\""$(pkgdatadir)"\" \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
+ -DPOLKIT_AGENT_I_KNOW_API_IS_SUBJECT_TO_CHANGE \
+ $(DISABLE_DEPRECATED) \
+ $(AM_CPPFLAGS)
+
+polkit_mate_authentication_agent_1_CFLAGS = \
+ $(GTK_CFLAGS) \
+ $(MATECONF_CFLAGS) \
+ $(POLKIT_AGENT_CFLAGS) \
+ $(POLKIT_GOBJECT_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(AM_CFLAGS)
+
+polkit_mate_authentication_agent_1_LDFLAGS = \
+ $(AM_LDFLAGS)
+
+polkit_mate_authentication_agent_1_LDADD = \
+ $(GTK_LIBS) \
+ $(MATECONF_LIBS) \
+ $(POLKIT_AGENT_LIBS) \
+ $(POLKIT_GOBJECT_LIBS) \
+ $(INTLLIBS)
+
+EXTRA_DIST = polkit-mate-authentication-agent-1.desktop.in.in
+
+clean-local :
+ rm -f *~ polkit-mate-authentication-agent-1.desktop polkit-mate-authentication-agent-1.desktop.in