summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 3 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 21baced..e845fa9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,35 +122,14 @@ MATE_COMPILE_WARNINGS([maximum])
# ***************************
GLIB_REQUIRED=2.36.0
+GTK_REQUIRED=3.14.0
POLKIT_AGENT_REQUIRED=0.97
POLKIT_GOBJECT_REQUIRED=0.97
APPINDICATOR_REQUIRED=0.0.13
-AC_MSG_CHECKING([which gtk+ version to compile against])
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk=2.0|3.0],[which gtk+ version to compile against (default: 2.0)])],
- [case "$with_gtk" in
- 2.0|3.0) ;;
- *) AC_MSG_ERROR([invalid gtk version specified]) ;;
- esac],
- [with_gtk=2.0])
-AC_MSG_RESULT([$with_gtk])
-
-case "$with_gtk" in
- 2.0) GTK_API_VERSION=2.0
- GTK_REQUIRED=2.24.0
- APPINDICATOR_API_VERSION=
- ;;
- 3.0) GTK_API_VERSION=3.0
- GTK_REQUIRED=3.0.0
- APPINDICATOR_API_VERSION=3
- ;;
-esac
-AC_SUBST(GTK_API_VERSION)
-
PKG_CHECK_MODULES(GLIB, glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GLIB_REQUIRED)
-PKG_CHECK_MODULES(GTK, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED)
+PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
@@ -169,7 +148,7 @@ AC_ARG_ENABLE([accountsservice],
AM_CONDITIONAL([HAVE_ACCOUNTSSERVICE], [test "x$enable_accountsservice" = xyes])
# Application indicator
-APPINDICATOR_PKG=appindicator$APPINDICATOR_API_VERSION-0.1
+APPINDICATOR_PKG=appindicator3-0.1
AC_ARG_ENABLE([appindicator],
AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for application indicators]),
@@ -267,7 +246,6 @@ echo "
cflags: ${CFLAGS}
cppflags: ${CPPFLAGS}
- Gtk+ version: ${GTK_API_VERSION}
Accountsservice: ${enable_accountsservice}
Application indicator: ${enable_appindicator}
Maintainer mode: ${USE_MAINTAINER_MODE}