summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 93f17f9..ac2131d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,15 +2,17 @@
FULL_LIBEXECDIR=$(libexecdir)
desktopdir = $(sysconfdir)/xdg/autostart
-desktop_DATA = polkit-mate-authentication-agent-1.desktop
-
-@INTLTOOL_DESKTOP_RULE@
+desktop_in_files = polkit-mate-authentication-agent-1.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
polkit-mate-authentication-agent-1.desktop.in : polkit-mate-authentication-agent-1.desktop.in.in Makefile
$(AM_V_GEN)sed \
-e "s|\@FULL_LIBEXECDIR\@|$(FULL_LIBEXECDIR)|" \
$< > $@
+$(desktop_DATA): $(desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
libexec_PROGRAMS = polkit-mate-authentication-agent-1
polkit_mate_authentication_agent_1_SOURCES = \
@@ -45,8 +47,7 @@ polkit_mate_authentication_agent_1_LDADD = \
$(GLIB_LIBS) \
$(POLKIT_AGENT_LIBS) \
$(POLKIT_GOBJECT_LIBS) \
- $(APPINDICATOR_LIBS) \
- $(INTLLIBS)
+ $(APPINDICATOR_LIBS)
EXTRA_DIST = \
polkit-mate-authentication-agent-1.desktop.in \