summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-07 10:38:37 +0200
committerraveit65 <[email protected]>2016-04-07 10:52:15 +0200
commit698d9f7891d3629a10b88ec825c717396c582040 (patch)
tree61b2afdec8a03ea6babb5bd8ca3f626a216c3a1f /Makefile.am
parent422b2ca14f2f5659910e1a1392593bde5e68fd10 (diff)
downloadmate-power-manager-698d9f7891d3629a10b88ec825c717396c582040.tar.bz2
mate-power-manager-698d9f7891d3629a10b88ec825c717396c582040.tar.xz
Add Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 17017f2..f416d57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,16 +39,13 @@ DISTCHECK_CONFIGURE_FLAGS = \
--disable-applets \
--disable-tests
-dist-hook:
- @if test -d "$(srcdir)/.git"; \
- then \
- echo Creating ChangeLog && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
- || ( rm -f ChangeLog.tmp ; \
- echo Failed to generate ChangeLog >&2 ); \
- else \
- echo A git clone is required to generate a ChangeLog >&2; \
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+