summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrent Hull <[email protected]>2012-12-15 20:04:05 -0500
committerBrent Hull <[email protected]>2012-12-15 20:04:05 -0500
commit5f86620759f2e522bda0e73f6c56fcb7c50d5295 (patch)
treed556e19c1196cfa1b159bf296216d766988b7f71 /configure.ac
parente8ce2f281bd7cb4597c9444983b7a0b6bbef0216 (diff)
downloadmate-power-manager-5f86620759f2e522bda0e73f6c56fcb7c50d5295.tar.bz2
mate-power-manager-5f86620759f2e522bda0e73f6c56fcb7c50d5295.tar.xz
Make mate-keyring support optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e15db51..f2db80c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,7 +151,6 @@ PKG_CHECK_MODULES(DBUS,[
PKG_CHECK_MODULES(MATE, [
gtk+-2.0 >= $GTK_REQUIRED
- mate-keyring-1 >= $MATE_KEYRING_REQUIRED
cairo >= $CAIRO_REQUIRED])
PKG_CHECK_MODULES(GDK, [
@@ -251,6 +250,22 @@ fi
AM_CONDITIONAL([HAVE_TESTS], [test $have_tests = yes])
dnl ---------------------------------------------------------------------------
+dnl - Build mate-keyring support
+dnl ---------------------------------------------------------------------------
+AC_ARG_WITH(keyring,
+ [AS_HELP_STRING([--without-keyring],
+ [Disable the use of mate-keyring])],
+ [],
+ [with_keyring=yes])
+
+AM_CONDITIONAL([WITH_KEYRING],[test "$with_keyring" = "yes"])
+
+if test "$with_keyring" = "yes"; then
+ PKG_CHECK_MODULES(KEYRING, mate-keyring-1 >= $MATE_KEYRING_REQUIRED)
+ AC_DEFINE([WITH_KEYRING],[1],[Define if KEYRING support is enabled])
+fi
+
+dnl ---------------------------------------------------------------------------
dnl - Build applets
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(applets,
@@ -400,6 +415,7 @@ echo "
datadir: ${datadir}
compiler: ${CC}
cflags: ${CFLAGS}
+ mate-keyring support: ${with_keyring}
Building extra applets: ${enable_applets}
Self test support: ${have_tests}
Use libunique: ${enable_libunique}