summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Zesch <[email protected]>2012-11-22 21:24:13 -0500
committerSteve Zesch <[email protected]>2012-11-22 21:24:13 -0500
commit4e4fac818bda769a9cdbafe2d88a78c764044b53 (patch)
treeee2343d1f07f29c845f1c1099fa9d5eaa53d3028 /configure.ac
parentde6402cb66f3eecfbb4aa92155f2cec7bc45225a (diff)
parent0415b57493898c5defa2719d67115f8ff2392904 (diff)
downloadmate-power-manager-4e4fac818bda769a9cdbafe2d88a78c764044b53.tar.bz2
mate-power-manager-4e4fac818bda769a9cdbafe2d88a78c764044b53.tar.xz
Merge branch 'master' of github.com:mate-desktop/mate-power-manager
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6e36106..748494b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,10 +280,12 @@ AC_ARG_WITH(systemdinhibit,
use_systemdinhibit=no
if test "x$with_systemdinhibit" != "xno" ; then
- use_systemdinhibit=yes
- AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])
+ PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login libsystemd-daemon, use_systemdinhibit=yes, use_systemdinhibit=no)
+
+ if test "x$use_systemdinhibit" = "xyes"; then
+ AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])
+ fi
- PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login libsystemd-daemon)
fi
AM_CONDITIONAL(WITH_SYSTEMD_INHIBIT, test x$use_systemdinhibit = xyes)
AC_SUBST(WITH_SYSTEMD_INHIBIT)