summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-07-23 01:33:10 -0700
committerStefano Karapetsas <[email protected]>2013-07-23 01:33:10 -0700
commit4c5c81c6bc16812cb62a53b7257167cddef28a7c (patch)
tree5340050689948130a567be5c3d0c9a32817c3ff1 /configure.ac
parent6ebb90a3029238c6d57fc67fd3ba2d2fbc4065a8 (diff)
parent247f3aeeffd20e0971641d8bb9ab1337f81991cd (diff)
downloadmate-power-manager-4c5c81c6bc16812cb62a53b7257167cddef28a7c.tar.bz2
mate-power-manager-4c5c81c6bc16812cb62a53b7257167cddef28a7c.tar.xz
Merge pull request #61 from lxnay/fix-github-master
Move logind / consolekit detection to runtime
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 0 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 3f9cb2e..863f2f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,48 +284,6 @@ AC_MSG_RESULT([$have_applets])
AM_CONDITIONAL([HAVE_APPLETS], [test $have_applets = yes])
dnl ---------------------------------------------------------------------------
-dnl systemd inhibit
-dnl ---------------------------------------------------------------------------
-
-AC_ARG_WITH(systemdinhibit,
- AS_HELP_STRING([--with-systemdinhibit],
- [Add systemdinhibit support]),,
- with_systemdinhibit=auto)
-
-use_systemdinhibit=no
-if test "x$with_systemdinhibit" != "xno" ; then
- PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login >= 195 libsystemd-daemon >= 195 , use_systemdinhibit=yes, use_systemdinhibit=no)
-
- if test "x$use_systemdinhibit" = "xyes"; then
- AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])
- fi
-
-fi
-AM_CONDITIONAL(WITH_SYSTEMD_INHIBIT, test x$use_systemdinhibit = xyes)
-AC_SUBST(WITH_SYSTEMD_INHIBIT)
-
-dnl ---------------------------------------------------------------------------
-dnl systemd sleep
-dnl ---------------------------------------------------------------------------
-
-AC_ARG_WITH(systemdsleep,
- AS_HELP_STRING([--with-systemdsleep],
- [Use logind for suspend and hibernate instead of upower]),,
- with_systemdsleep=auto)
-
-use_systemdsleep=no
-if test "x$with_systemdsleep" != "xno" ; then
- PKG_CHECK_MODULES(SYSTEMD_SLEEP, libsystemd-login >= 195 libsystemd-daemon >= 195 , use_systemdsleep=yes, use_systemdsleep=no)
-
- if test "x$use_systemdsleep" = "xyes"; then
- AC_DEFINE(WITH_SYSTEMD_SLEEP, 1, [systemdsleeo support])
- fi
-
-fi
-AM_CONDITIONAL(WITH_SYSTEMD_SLEEP, test x$use_systemdsleep = xyes)
-AC_SUBST(WITH_SYSTEMD_SLEEP)
-
-dnl ---------------------------------------------------------------------------
dnl - DocBook Documentation
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(docbook-docs,