summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-11-01 17:33:16 -0700
committerStefano Karapetsas <[email protected]>2012-11-01 17:33:16 -0700
commit7c7b09026bde3ffd1ce886fd545e7bfa1e59aec7 (patch)
tree076ec7419159262e65f608da7a3dbccdd8ec3a5a /data/Makefile.am
parent83dc101045267b2e793af3af4716f1cf02089ac6 (diff)
parent972be3627b8b6368a0e8c971ade7963ea7d459de (diff)
downloadmate-power-manager-7c7b09026bde3ffd1ce886fd545e7bfa1e59aec7.tar.bz2
mate-power-manager-7c7b09026bde3ffd1ce886fd545e7bfa1e59aec7.tar.xz
Merge pull request #19 from bhull2010/gsettings
Port to Gsettings
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am33
1 files changed, 11 insertions, 22 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 80b8a49..06aab6e 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,9 +1,5 @@
SUBDIRS = icons
-@INTLTOOL_SCHEMAS_RULE@
-schemadir = $(sysconfdir)/mateconf/schemas
-schema_in_files = mate-power-manager.schemas.in
-schema_DATA = $(schema_in_files:.schemas.in=.schemas)
@INTLTOOL_DESKTOP_RULE@
desktopdir = $(datadir)/applications
@@ -23,6 +19,11 @@ service_DATA = $(service_in_files:.service.in=.service)
$(service_DATA): $(service_in_files) Makefile
@sed -e "s|\@servicedir\@|$(bindir)|" $< > $@
+@GSETTINGS_RULES@
+@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_schemas_in_files = org.mate.power-manager.gschema.xml.in
+gsettings_SCHEMAS = $(gsettings_schemas_in_files:.gschema.xml.in=.gschema.xml)
+
pkgdata_DATA = \
gpm-statistics.ui \
gpm-statistics-deprecated.ui \
@@ -32,25 +33,13 @@ pkgdata_DATA = \
acme.ui
EXTRA_DIST = \
- mate-power-manager.schemas.in \
- $(schema_in_files) \
- $(desktop_in_files) \
- $(autostart_in_files) \
+ $(gsettings_SCHEMAS) \
$(service_in_files) \
+ $(autostart_in_files) \
+ $(desktop_in_files) \
+ $(gsettings_schemas_in_files) \
$(pkgdata_DATA)
-if MATECONF_SCHEMAS_INSTALL
-install-data-local:
- -MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) \
- $(MATECONFTOOL) --makefile-install-rule $(schema_DATA)
-endif
-
-if MATECONF_SCHEMAS_INSTALL
-uninstall-local:
- -MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) \
- $(MATECONFTOOL) --makefile-uninstall-rule $(schema_DATA)
-endif
-
clean-local :
rm -f *~
@@ -58,5 +47,5 @@ DISTCLEANFILES = \
mate-power-manager.desktop \
mate-power-preferences.desktop \
mate-power-statistics.desktop \
- mate-power-manager.schemas \
- mate-power-manager.service
+ mate-power-manager.service \
+ org.mate.power-manager.gschema.xml