summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 15 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 460dce3..b464416 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
-ACLOCAL_AMFLAGS = -I m4
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAG}
SUBDIRS = \
src \
@@ -16,11 +16,12 @@ SUBDIRS += applets
endif
EXTRA_DIST = \
+ autogen.sh \
HACKING \
+ NEWS.GNOME \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in \
- mate-doc-utils.make
+ intltool-update.in
clean-local :
rm -f *~
@@ -40,23 +41,16 @@ DISTCHECK_CONFIGURE_FLAGS = \
--disable-applets \
--disable-tests
-distclean-local:
- if test $(srdcir) = .; then :; else \
- rm -f ChangeLog; \
- fi
-
-ChangeLog:
- @echo Creating $@
- @if test -d "$(srcdir)/.git"; then \
- (GIT_DIR=$(top_srcdir)/.git ./missing --run git log --stat -M -C --name-status --date=short --no-color) | fmt --split-only > [email protected] \
- && mv -f [email protected] $@ \
- || ($(RM) [email protected]; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
- (test -f $@ || echo git-log is required to generate this file >> $@)); \
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
else \
- test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
+ echo A git clone is required to generate a ChangeLog >&2; \
fi
-
-.PHONY: ChangeLog