summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eee06d9..a13d439 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,12 @@ IT_PROG_INTLTOOL([0.50.1])
MATE_COMPILE_WARNINGS
YELP_HELP_INIT
+# GLib min/max required versions
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs added after GLib 2.36])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs deprecated before GLib 2.36])
+
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
dnl ---------------------------------------------------------------------------