summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 2 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index 2eff3d0..912c362 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ(2.63)
-AC_INIT([mate-power-manager], [1.6.1], [http://www.mate-desktop.org/])
+AC_INIT([mate-power-manager], [1.6.2], [http://www.mate-desktop.org/])
AC_CONFIG_SRCDIR(src)
AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-xz])
AC_CONFIG_HEADERS([config.h])
@@ -139,7 +139,7 @@ esac
dnl ---------------------------------------------------------------------------
dnl - Check library dependencies
dnl ---------------------------------------------------------------------------
-PKG_CHECK_MODULES(GLIB, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 gio-2.0 >= $GIO_REQUIRED)
+PKG_CHECK_MODULES(GLIB, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 gio-2.0 >= $GIO_REQUIRED gio-unix-2.0)
PKG_CHECK_MODULES(CANBERRA, libcanberra-gtk >= $CANBERRA_REQUIRED)
@@ -284,48 +284,6 @@ AC_MSG_RESULT([$have_applets])
AM_CONDITIONAL([HAVE_APPLETS], [test $have_applets = yes])
dnl ---------------------------------------------------------------------------
-dnl systemd inhibit
-dnl ---------------------------------------------------------------------------
-
-AC_ARG_WITH(systemdinhibit,
- AS_HELP_STRING([--with-systemdinhibit],
- [Add systemdinhibit support]),,
- with_systemdinhibit=auto)
-
-use_systemdinhibit=no
-if test "x$with_systemdinhibit" != "xno" ; then
- PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login >= 195 libsystemd-daemon >= 195 , use_systemdinhibit=yes, use_systemdinhibit=no)
-
- if test "x$use_systemdinhibit" = "xyes"; then
- AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])
- fi
-
-fi
-AM_CONDITIONAL(WITH_SYSTEMD_INHIBIT, test x$use_systemdinhibit = xyes)
-AC_SUBST(WITH_SYSTEMD_INHIBIT)
-
-dnl ---------------------------------------------------------------------------
-dnl systemd sleep
-dnl ---------------------------------------------------------------------------
-
-AC_ARG_WITH(systemdsleep,
- AS_HELP_STRING([--with-systemdsleep],
- [Use logind for suspend and hibernate instead of upower]),,
- with_systemdsleep=auto)
-
-use_systemdsleep=no
-if test "x$with_systemdsleep" != "xno" ; then
- PKG_CHECK_MODULES(SYSTEMD_SLEEP, libsystemd-login >= 195 libsystemd-daemon >= 195 , use_systemdsleep=yes, use_systemdsleep=no)
-
- if test "x$use_systemdsleep" = "xyes"; then
- AC_DEFINE(WITH_SYSTEMD_SLEEP, 1, [systemdsleeo support])
- fi
-
-fi
-AM_CONDITIONAL(WITH_SYSTEMD_SLEEP, test x$use_systemdsleep = xyes)
-AC_SUBST(WITH_SYSTEMD_SLEEP)
-
-dnl ---------------------------------------------------------------------------
dnl - DocBook Documentation
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(docbook-docs,
@@ -439,8 +397,6 @@ echo "
Building extra applets: ${enable_applets}
Self test support: ${have_tests}
Use libunique: ${enable_libunique}
- systemd support: ${use_systemdinhibit}
- systemd sleep support: ${use_systemdsleep}
Docbook support: ${enable_docbook_docs}
documentation dir: $DOCDIR
dbus-1 services dir: $DBUS_SERVICES_DIR