summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 3f9cb2e..511833d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -305,27 +305,6 @@ AM_CONDITIONAL(WITH_SYSTEMD_INHIBIT, test x$use_systemdinhibit = xyes)
AC_SUBST(WITH_SYSTEMD_INHIBIT)
dnl ---------------------------------------------------------------------------
-dnl systemd sleep
-dnl ---------------------------------------------------------------------------
-
-AC_ARG_WITH(systemdsleep,
- AS_HELP_STRING([--with-systemdsleep],
- [Use logind for suspend and hibernate instead of upower]),,
- with_systemdsleep=auto)
-
-use_systemdsleep=no
-if test "x$with_systemdsleep" != "xno" ; then
- PKG_CHECK_MODULES(SYSTEMD_SLEEP, libsystemd-login >= 195 libsystemd-daemon >= 195 , use_systemdsleep=yes, use_systemdsleep=no)
-
- if test "x$use_systemdsleep" = "xyes"; then
- AC_DEFINE(WITH_SYSTEMD_SLEEP, 1, [systemdsleeo support])
- fi
-
-fi
-AM_CONDITIONAL(WITH_SYSTEMD_SLEEP, test x$use_systemdsleep = xyes)
-AC_SUBST(WITH_SYSTEMD_SLEEP)
-
-dnl ---------------------------------------------------------------------------
dnl - DocBook Documentation
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(docbook-docs,