summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-08-17 00:08:16 +0200
committerVictor Kareh <[email protected]>2019-08-22 13:48:25 -0400
commit2ce29e42f9ad5b5b618fb726e264b850f59cbebc (patch)
treeb698708fd487af3086d14a52a93b8d2e927ab987 /configure.ac
parentd46b6e8d7a6e8df18d2c8605979e86b10f7920d5 (diff)
downloadmate-screensaver-2ce29e42f9ad5b5b618fb726e264b850f59cbebc.tar.bz2
mate-screensaver-2ce29e42f9ad5b5b618fb726e264b850f59cbebc.tar.xz
Use gresources for mate-screensaver-preferences.ui
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 05984ec..ee88500 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,21 @@ SAVER_LIBS="$ALL_X_LIBS"
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+# GLIB_COMPILE_RESOURCES
+
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# XMLLINT
+
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
MATE_COMPILE_WARNINGS(yes)