summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-11-12 14:33:34 +0100
committerStefano Karapetsas <[email protected]>2012-11-12 14:33:34 +0100
commit49b028e85839da7006b4857cf323a7cbee91316c (patch)
tree5bff18351d439b781f10054dba7a46b8aef308f5 /src/Makefile.am
parent77ac5c607d0f0562aad4ab9573c4b85003216c0c (diff)
downloadmate-screensaver-49b028e85839da7006b4857cf323a7cbee91316c.tar.bz2
mate-screensaver-49b028e85839da7006b4857cf323a7cbee91316c.tar.xz
add support for systemd-logind
http://git.gnome.org/browse/gnome-screensaver/commit/?id=6bb98e9acb9391d1aec8f7dcb44ef7d16b3dcb91 https://bugzilla.gnome.org/show_bug.cgi?id=669787
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1de819f..272b931 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -31,6 +31,7 @@ INCLUDES = \
$(DBUS_CFLAGS) \
$(LIBMATEKBDUI_CFLAGS) \
$(LIBMATENOTIFY_CFLAGS) \
+ $(SYSTEMD_CFLAGS) \
$(NULL)
bin_PROGRAMS = \
@@ -213,6 +214,7 @@ mate_screensaver_gl_helper_SOURCES = \
mate_screensaver_LDADD = \
$(MATE_SCREENSAVER_LIBS) \
$(SAVER_LIBS) \
+ $(SYSTEMD_LIBS) \
$(NULL)
mate_screensaver_LDFLAGS = -export-dynamic